В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
goplanozvgqa
goplanozvgqa
05.06.2021 15:07 •  Информатика

Программа на c++ напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. входные данные входная строка содержит два целых числа. выходные данные программа должна вывести произведение введённых чисел. примеры входные данные 6 12 выходные данные 72 входные данные -7 15 выходные данные -105

Ответ:
tanyushchik
tanyushchik
09.09.2020 21:27
#include <iostream>
using namespace std;  

int multiply(int x, int y)
{
    if(y == 0)
      return 0;
      if(y > 0)
      return (x + multiply(x, y - 1));
       if(y < 0)
      return -multiply(x, -y);
}
   
int main()
{
   int a, b;
   cin >> a >> b;
   cout << multiply(a, b) << endl;
   return 0;
}
0,0(0 оценок)
Ответ:
СтилРайдер
СтилРайдер
09.09.2020 21:27
#include <cstdio>
#include <cstdlib>

int
main(void)
{
    int a = 0;
    int b = 0;
    scanf("%d %d", &a, &b);
    long long mul = 0;
    for (int i = 0; i < abs(a); i++) {
        mul += b;
    }
    if (a < 0) {
        mul = -mul;
    }
    printf("%lld\n", mul);
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?