В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
olia108
olia108
18.12.2022 10:51 •  Информатика

Написать программу в с++, которая проверяла бы: "число армстронга или нет". если что, число армстронга-это число в котором сумма цифр=самому числу. причем каждая цифра в таком степени, сколько цифр в самом числе, например число 153-армстронга, потому что 153=1³+5³+3³. если можно,напишите программу так, чтоб я, как новичок понял, решить через функции.

Ответ:
Chelovekkkkkkk1701
Chelovekkkkkkk1701
06.10.2020 22:36
#include <iostream>
#include <cmath>
using namespace std;

void isArmstrong(const int number)
{
int origNum, num, rem, sum = 0;
origNum = number;
num = origNum;
while(num != 0) {
rem = num % 10;
sum += pow(rem, 3);
num /= 10;
}

if(sum == origNum)
cout << origNum << " is an Armstrong number.";
else
cout << origNum << " is not an Armstrong number.";
}

int main()
{
isArmstrong(153);
return 0;
}

С проверкой https://ideone.com/keY6PS
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?