Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Danielkz02
16.06.2021 13:11 •
Информатика
Написать программу в паскале, определяющую является ли число перевертышем в паскаль. p.s перевертыш т.е с двух сторон читается одинаково, например 111
Ответ:
lizarepkina2004
06.10.2020 22:21
// PascalABC.NET 3.3, сборка 1542 от 05.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Введите натуральное число: ').ToString;
if n=ReverseString(n) then Writeln('Перевертыш')
else Writeln('не перевертыш')
end.
Пример
Введите натуральное число: 3527253
Перевертыш
Введите натуральное число: 135233
не перевертыш
0,0
(0 оценок)
Популярные вопросы: Информатика
almazbekovash34
28.05.2023 06:37
Найти сумму от начала до первого кратного 5...
оля2044
28.05.2023 06:37
Вывести номер 1 и последнего кратного 5 pascal abc...
Anonim2118
05.12.2021 20:43
Придумать и решить с небольшую задачу. Требования к задаче: 1) Текст задачи (условие придумать самостоятельно). 2) оформление таблицы (границы, объединение ячеек, формат ячеек) 3)...
raizat2004
24.03.2023 23:56
Составить рограмму на языке паскаль: введите 3 числа и выведите колличество одинаковых чисел в этой цепочке (может быть 3 или 2 или 0)....
bogodist68
09.01.2022 07:45
Решите уравнение (x^2-a^2)=ax+1 относительно x....
cheburejp00xj4
09.01.2022 07:45
Конь с розовой гривой какие темы были в рассказе конь с розовой гривой? (типо жалость ну чтот тип такого) и почему совесть называется высшим законом и судьёй...
66vdv1
09.01.2022 07:45
1. какие металлы будут вытеснять медь из водных растворов ее солей: 1) аu 2) mg 3) na 4) ag 2.раствор бромида меди (ii) реагирует с каждым из перечисленных веществ: 1) вас12 и zn...
Апслтел
09.01.2022 07:45
Знайдіть площу поверхні прямої чотирикутної призми бічне ребро якої дорівнює 5 см, а сторони основи 2 см, 3 см, 2,5 см, 4,5 см...
AbaiMalik05
27.11.2021 01:30
Три котёнка — чёрный, серый и белый — увидели мышь и бросились за ней! мышь прыгнула в банку с мукой. котята — за ней! мышь убежала. а из банки вылезли три белых котёнка. три белых...
александрадейкун
27.11.2021 01:30
Какой величины работу совершает кран, поднимая блок весом в 3 тонн на высоту 6 м? принять, что g≈10 н/кг ответ: работа, совершённая краном, равна кдж....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Введите натуральное число: ').ToString;
if n=ReverseString(n) then Writeln('Перевертыш')
else Writeln('не перевертыш')
end.
Пример
Введите натуральное число: 3527253
Перевертыш
Введите натуральное число: 135233
не перевертыш