В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
rushsh1
rushsh1
22.11.2022 05:27 •  Информатика

Надо сдать эти работы! 60 ! написать все программы на языке с++ 1) в массиве в(11) все элементы из интервала (a,b) занесите в массив с и найдите сумму элементов полученного массива. 2) написать программу, которая по вводимому числу от 1 до 11 ( номер класса) выдает соответствующее сообщение " k-классник". например k=1 " первоклассник", если k=4 " четвероклассник. 3) дано число х. напечатать в порядке возрастания числа sin(x), cos(x), ln(x). если при каком-либо х некоторые из выражений не имеют смысла, вывести об этом сообщение и сравнивать значения только тех, которые имеют смысл."

Ответ:
kostetXD
kostetXD
06.10.2020 22:04
Вторая:
#include <iostream>
using namespace std;
int main(){    setlocale(LC_ALL, "Russian");
    int form;    cin >> form;    string sForm[11] = {        "первоклассник","второклассник","третьеклассник","четвероклассник","пятиклассник",        "шестиклассник","семиклассник","восьмиклассник","девятиклассник","десятиклассник",        "одиннадцатиклассник"    };    cout << "Привет, " << sForm[form-1];    return 0;}

Первая:
Не совсем понятно условие - ввода для заполнения массива B нет. Поэтому пишу лишь основную часть кода.
int sum = 0;
for(int i=0;i<b-a;i++){
        C[i] = B[a+i];
        sum += B[a+i];
}

Третья:
#include <iostream>#include <cmath>
using namespace std;
int main(){    int x;    cin >> x;    double result[3];    result[0] = sin(x);    result[1] = cos(x);    result[2] = log(x);    bool finished = false;    while(!finished){        finished = true;        for(int i=0;i<2;i++){            if(result[i] < result[i+1]){                int buf = result[i];                result[i] = result[i+1];                result[i+1] = buf;                finished = false;            }        }    }    for(int i=0;i<3;i++){        if(result[i] == result[i] && abs(result[i]) != HUGE_VAL)        cout << result[i] << endl;    }    return 0;}

Примечание к коду: result[i] == result[i] - это проверка, является ли число неопределенным.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?