Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
olesyaprk
25.03.2022 18:59 •
Информатика
Решить в паскале у гусей и кроликов вместе 64 лапы. сколько может быть кроликов и гусей (указать все сочетания которые возможны). использовать while do (без inc)
Ответ:
4новичок4
06.10.2020 22:00
Var a,b:integer;
begin
while a*4<65 do
begin
writeln('кролик: ',a,' гусь: ',(64-a*4) div 2);
a:=a+1;
end;
end.
0,0
(0 оценок)
Ответ:
AnastasiaNastia55555
06.10.2020 22:00
Var k:integer;
begin
k:=0;
while k*4<=64 do
begin
writeln('кроликов: ',k,', гусей: ',(64-k*4) div 2);
k:=k+1;
end;
end.
Результат:
кроликов: 0, гусей: 32
кроликов: 1, гусей: 30
кроликов: 2, гусей: 28
кроликов: 3, гусей: 26
кроликов: 4, гусей: 24
кроликов: 5, гусей: 22
кроликов: 6, гусей: 20
кроликов: 7, гусей: 18
кроликов: 8, гусей: 16
кроликов: 9, гусей: 14
кроликов: 10, гусей: 12
кроликов: 11, гусей: 10
кроликов: 12, гусей: 8
кроликов: 13, гусей: 6
кроликов: 14, гусей: 4
кроликов: 15, гусей: 2
кроликов: 16, гусей: 0
0,0
(0 оценок)
Популярные вопросы: Информатика
manzharenko13
18.11.2020 20:23
Отметьте все правильные высказывания о файл-серверных СУБД: обработку данных выполняет сервер; рабочие станции могут быть маломощными; основная нагрузка приходится на сервер;...
anastasia538
13.08.2021 01:09
Сообщение, записанное буквами из 32-символьного алфавита, содержит 400 символов. Какой объём информации в байтах оно несёт?...
Shady2002
05.09.2022 18:25
Какие форматы файлов используются для хранения векторных рисунков? 1.bmp 2.jpg 3.svg 4.cdr 5.wmf...
лиза4710
04.12.2022 07:47
Python Визначити, чи є введене слово ідентифікатором, тобто починається воно з літери англійського алфавіту (малої або великої) або знака підкреслення і не містить інших символів,...
Голес
10.01.2021 23:36
Длина текстового сообщения — 256 символов. Объём файла получился 160 байт. Определи наименьшее и наибольшее количество символов в алфавите, которое использовал Магир при написании...
arsyuha
21.01.2020 09:14
Каков результат выполнения алгоритма при: х1=8, х2= -7, х3 =0...
mo14yn
03.04.2021 01:28
На рисунке – схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, И, К. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой.Сколько существует различных...
Infinity167
22.10.2021 08:19
Прямоугольный параллелепипед с ребрами 23,46 и 69. Предикат: Vol(a,b,c,v):=Mult(a,b,z),Mult(z,c,v). За...
danisimokuvshn
19.02.2021 02:38
Переведите число 10100101 в десятичную систему счисления...
valikotura
01.05.2021 06:08
тут надо сделать ну рассказать про это...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
while a*4<65 do
begin
writeln('кролик: ',a,' гусь: ',(64-a*4) div 2);
a:=a+1;
end;
end.
begin
k:=0;
while k*4<=64 do
begin
writeln('кроликов: ',k,', гусей: ',(64-k*4) div 2);
k:=k+1;
end;
end.
Результат:
кроликов: 0, гусей: 32
кроликов: 1, гусей: 30
кроликов: 2, гусей: 28
кроликов: 3, гусей: 26
кроликов: 4, гусей: 24
кроликов: 5, гусей: 22
кроликов: 6, гусей: 20
кроликов: 7, гусей: 18
кроликов: 8, гусей: 16
кроликов: 9, гусей: 14
кроликов: 10, гусей: 12
кроликов: 11, гусей: 10
кроликов: 12, гусей: 8
кроликов: 13, гусей: 6
кроликов: 14, гусей: 4
кроликов: 15, гусей: 2
кроликов: 16, гусей: 0