В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
artemykas
artemykas
23.07.2022 16:39 •  Информатика

Написать программу для pascal. программа считывает с клавиатуры массив из n элементов(n < 1000) и выводит максимальный и минимальный элемент массива и их среднее арифметическое

Ответ:
yuliav1801
yuliav1801
06.10.2020 20:51
// PascalABC.NET 3.3, сборка 1540 от 16.09.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrReal('Вводите элементы массива'+NewLine,ReadInteger('n='));
  Writeln('Max=',a.Max,', min=',a.Min,', среднее=',(a.Min+a.Max)/2)
end.

Пример
n= 8
Вводите элементы массива
  3.45 -2.7 1.18 0 -2 4.623 -2.734 7
Max=7, min=-2.734, среднее=2.133
0,0(0 оценок)
Ответ:
Maruua1
Maruua1
06.10.2020 20:51
1.
var x : array[1..1000] of integer; 
  n,i,max,min : integer;
begin
write('n = ');
readln(n);
writeln('Исходный массив:');
for i:=1 to n do begin
 write('x[',i,']=');
 readln(x[i]);
 end;
writeln;
max:=x[1]; min:=x[1];
for i:=2 to n do
 begin
 if x[i] > max then max:=x[i];
 if x[i] < min then min:=x[i];
 end;
writeln('max=',max,'  min=',min);
writeln('Среднее = ',(max+min)/2:5:2);
end.

Пример:
n = 5
Исходный массив:
x[1]=12
x[2]=45
x[3]=60
x[4]=72
x[5]=68
max=72 min=12
Среднее = 42.00



2.
begin
  var n:=ReadInteger('n = ');
  var a:=ReadArrInteger('Вводите массив:',n);
  Writeln('Max = ',a.Max);
  Writeln('Min = ',a.Min);
  Writeln('Среднее = ',(a.Max+a.Min)/2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?