Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
soborsasha
25.04.2022 01:53 •
Информатика
Написать код на паскале, который выполняет следующие условия если x> 0 c=x*y^2 если x< 0 c=x-y если x=0 c=x+y
Ответ:
поать
06.10.2020 20:41
// PascalABC.NET 3.3, сборка 1540 от 16.09.2017
// Внимание! Если программа не работает, обновите версию!
begin
var (x,y):=ReadReal2('Введите х и у через пробел-');
var c:real;
if x>0 then c:=x*y*y
else
if x<0 then c:=x-y
else c:=x+y;
Writeln(c)
end.
Пример
Введите х и у через пробел- 3.18 -5.2
85.9872
0,0
(0 оценок)
Популярные вопросы: Информатика
Борель
20.08.2021 22:42
Насколько важно содержание информационного дизайна интерфейса...
Mаs9n9
13.04.2023 11:20
Срешением логической программист может осуществлять два вида деятельности: писать код. пить кофе. когда программист пишет код, он устает. поэтому на каждую следующую строчку кода...
Afyz1
14.02.2023 15:08
Как в ворде скопировать текст и картинку, чтобы сгруппировать их?...
mzhenyak1999
14.02.2023 15:08
Если при наборе текста все буквы отображаются прописными, то это означает, что нажата клавиша варианты num lock cars lock f1...
angelinaangelka
16.05.2020 02:14
Положительные и отрицательные качества хакерства (несколько)...
bigofficerjor
17.01.2022 08:08
Напишите основание системы счисления, если 110ₓ=12₁₀...
anod7936
17.01.2022 08:08
4. установіть відповідність між зображень комп’ютерної графіки та об’єктами, з яких воно складається а) векторне 1) подібних між собою об’єктів б) растрове 2) об’ємних об’єктів...
anymay20041302
21.09.2022 05:40
Напишите развернутую запись числа 135,43 в десятичной системе счисления...
TAISKAKISKA
21.09.2022 04:11
Соч по информатике 2 четверть, есть у кого нибудь? ! , завтра уже пишем...
PomoGayka0
27.06.2022 21:04
Python написать программу, которая запрашивает число, и если оно 4597 печатает как хорошо иначе иди, учи информатику...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var (x,y):=ReadReal2('Введите х и у через пробел-');
var c:real;
if x>0 then c:=x*y*y
else
if x<0 then c:=x-y
else c:=x+y;
Writeln(c)
end.
Пример
Введите х и у через пробел- 3.18 -5.2
85.9872