В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nikolay946
nikolay946
06.03.2023 17:03 •  Информатика

Вpascalabc напишите программу, которая выводит все простые числа в диапазоне от k до n ( 2 ≤ k ≤ n ≤ 100000 ), у которых первая и последняя цифры десятичной записи одинаковые. входные данные входная строка содержит два натуральных числа, разделённые пробелом, k и n ( 2 ≤ k ≤ n ≤ 100000 ). выходные данные программа должна вывести все простые числа, у которых одинаковые первая и последняя цифры десятичной записи, в диапазоне от k до n в одну строку, разделив их пробелами. если таких чисел нет, нужно вывести число 0. примеры входные данные 100 200 выходные данные 101 131 151 181 191 входные данные 20 30 выходные данные 0

Ответ:
Mtaraska
Mtaraska
06.10.2020 20:40
Program n1;
var k,n,i: longint;
co: byte;
function simply(a: longint ):boolean;
var i: longint;
begin
simply:=true;
for i:=2 to trunc(sqrt(a)) do begin if a mod i=0 then begin
simply:=false;
break
end
end
end;
function cr(a: longint): boolean;
var n: longint;
begin
n:=a;
cr:=false;
repeat
n:=n div 10;
until n mod 10 =n;
if n=(a mod 10) then
begin
cr:=true;
end;
end;
begin
readln(k,n);
for i:=k to n do if simply(i) then begin if (i=2) or (i=3) or (i=5) or (i=7) or cr(i) then
begin
write(i,' ');
co:=1;
end
end;
if co=0 then write(0);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?