В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zannaeroshik505
zannaeroshik505
02.08.2022 20:40 •  Информатика

Задано двухзначное число. составить программу, которая отвечает на вопрос, правда ли, что все его цифры чётные

Ответ:
ibrashovo
ibrashovo
06.10.2020 20:30
// PascalABC.NET 3.3, сборка 1540 от 16.09.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите двухзначное натуральное число:');
  if (n div 10).IsEven and (n mod 10).IsEven then Writeln('Да')
  else Writeln('Нет')
end.

Пример
Введите двухзначное натуральное число: 28
Да
0,0(0 оценок)
Ответ:
ellalavrina
ellalavrina
06.10.2020 20:30
Program oddn;
var
a,b,c: integer;

begin
readln(c);
a:=c div 10;
b:=c - a*10;
if (a and 1=0) and (b and 1=0) then
writeln('все цифры четные')
else
writeln('есть нечетные цифры');

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?