В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Ilyavazhnov1995
Ilyavazhnov1995
21.11.2022 23:44 •  Информатика

Составить программу, которая бы определяла с гласной ли буквы начинается введенное слово и определить первая буква совпадает с заданной . в паскале

Ответ:
ilyazavrik
ilyazavrik
06.10.2020 20:00
// PascalABC.NET 3.3, сборка 1540 от 16.09.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите слово:').ToLower;
  var c:=ReadlnChar('Введите букву:').ToLower;
  if Pos(s[1],'аеёиоуыэюя')>0 then Writeln('Слово начинается с гласной')
  else Writeln('Слово начинается не с гласной');
  If s[1]=c then Writeln('Слово начинается с указанной буквы')
  else Writeln('Слово не начинается с указанной буквы')
end.

Примеры
Введите слово: Арбуз
Введите букву: к
Слово начинается с гласной
Слово не начинается с указанной буквы

Введите слово: Барабан
Введите букву: б
Слово начинается не с гласной
Слово начинается с указанной буквы
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?