В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
romanenckoalia
romanenckoalia
19.05.2022 19:11 •  Информатика

Нужно написать программу в ms visual c#, .. услуги телефонной сети оплачиваются по следующему правилу: за разговоры до а минут в месяц – в рублей за минуту, а разговоры сверх установленной нормы оплачиваются из расчета с рублей за минуту. требуется написать программу, вычисляющую плату за пользование телефоном для введенного времени разговоров за месяц.

Ответ:
настящасте
настящасте
03.08.2020 19:55
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace zn
{
    class Program
    {
        public static void Main(string[] args)
        {
            Console.Write("Введите кол-во минут по тарифу: ");
            int a = Convert.ToInt32(Console.ReadLine());
            Console.Write("Введите цену за минуту по тарифу: ");
            int b = Convert.ToInt32(Console.ReadLine());
            Console.Write("Введите цену за минуту сверх тарифа: ");
            int c = Convert.ToInt32(Console.ReadLine());
            Console.Write("Введите время пользования услугами связи за месяц в минутах: ");
            int d = Convert.ToInt32(Console.ReadLine());
            int res = a > d ? a * b : a * b + (d - a) * c;
            Console.WriteLine("Плата за пользование: " + res);
            Console.ReadKey();
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?