Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
varenik506
04.08.2022 21:51 •
Информатика
Лёгкая по информатике паскаль. по заданному числу x и целому n вычислить x^n используя цикл .
Ответ:
KINGAsyaKING
06.10.2020 19:25
Var x,xn:real; n,i:integer;
begin
readln(x,n);
xn:=1; i:=0;
repeat
i:=i+1;
xn:=xn*x;
until i=abs(n);
if n<0 then xn:=1/xn;
writeln(x:3:1,'^',n,' = ',xn:6:4);
end.
Пример:
2 -3
2.0^-3 = 0.1250
0,0
(0 оценок)
Популярные вопросы: Информатика
zvonilovakarina
08.03.2021 17:33
Постройте семантическую сеть на основе текста: «Кошачьи — семейство млекопитающих отряда хищных. Кроме кошек к ним относятся, например, львы и тигры. У кошачьих развиты...
RFHBYF456
19.10.2022 14:29
Какое количество информации несет один знак сообщения, если используется 256-символьный алфавит?...
PRI3E
08.03.2020 22:48
2. найдите информационный объем набранного на пк предложения: язык – это знаковый представления информации....
sirius830
18.10.2022 22:45
Определи значение переменной а после выполнения алгоритма (в программе : = обозначает оператор присваивания, знаки + , - , * и / - соответственно операции сложения,...
Милка98806
20.12.2021 17:27
Фруктовый магазин продает яблоки поштучно по 10 руб., груши- по 20руб., апельсины-по 30 руб. впервые два дня недели продано: понедельник- х яблок, у груш, z апельсинов;...
ОМОН07
19.10.2020 16:31
Нужно написать программу для нахождения суммы цифр любого трехзначного числа, вводимого с клавиатуры во время работы программы)) как это сделать с mod или div без...
Marmaladee
21.07.2022 18:08
Вид знака, который свои видом говорит нам что он обозначает символ пиктограмма...
Sofka11123
31.10.2020 15:27
Установите соответствие между типами соединения костей и примерами: а.позвонки крестцового отдела б.тазобедренный сустав в.коленный сустав г.кости черепа д.позвонки...
wenefep07126
31.10.2020 15:27
Определите за какое время нитяной маятник совершит 40 колебаний, если за 60с он совершит 120 колебаний.чему равен период колебания? , и если можно еще нужно что дано...
janibek01
31.10.2020 15:27
Сократить дробь: х²+6х-7 / х²-7х+6...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
readln(x,n);
xn:=1; i:=0;
repeat
i:=i+1;
xn:=xn*x;
until i=abs(n);
if n<0 then xn:=1/xn;
writeln(x:3:1,'^',n,' = ',xn:6:4);
end.
Пример:
2 -3
2.0^-3 = 0.1250