В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Julia13662004
Julia13662004
23.01.2021 15:17 •  Информатика

По информатике в паскале. : составить программу вычисления суммы цифр числа, если кол-во неизвестно.

Ответ:
Vbeker
Vbeker
06.10.2020 16:52
Uses crt;
var a,b: Integer;
Begin
Write('Введите целое число: ');
Read a;
While a>0 do
Begin
b:=b+a mod 10;
a:=a div 10;
End;
Writeln('Сумма цифр введённого числа равна ', b);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?