В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vasiaplaton
vasiaplaton
15.09.2020 00:46 •  Информатика

Нужно написать программу на вход в pascal программа получает 3 действительных числа- значение градусных мер углов треугольника 1 программа должна проверить что это треугольник ( сложить 3 угла и получить 180) 2 программа должна вывести какой это треугольник( равнобедренный 2 угла равны, равносторонний все 3 угла равны 60, или прямоугольный угол 90) 3 если это прямоугольный треугольник то программа должна запросить 2 стороны треугольника ( 2 катета) и найти его площадь. ( площадь равна половине произведения катетов) написать программу в pascal 99

Ответ:
teddybear1812
teddybear1812
06.10.2020 16:51
Uses crt;
var a,b,c: Integer;
Begin
Write('Введите три угла: ');
Readln(a, b, c);
If (a+b+c)=180 then
Writeln('Это треугольник')
Else Writeln('Это не треугольник');
End.

Вторая:
uses crt;
var a,b,c: Integer;
Begin
Write('Введите три угла: ');
Read(a,b,c);
If (a=b) or (a=c) or (b=c) then
Writeln('Треугольник равнобедренный');
End.

Третья:
uses crt;
var a,b,c: Integer;
d,e,f: Real;
Begin
Write('Введите три угла: ');
Readln(a,b,c);
If (a=90) or (b=90) or (c=90) then
Write('Введите два катета: ');
Readln(d,e);
f:=(d+e)/2;
Writeln('Площадь треугольника: ', f, '.');
End.

Если надо объединить в одну - пиши.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?