В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hdhdydjsh
hdhdydjsh
29.12.2020 13:23 •  Информатика

1. составить программу нахождения для заданного натурального числа всех делителей, заканчивающихся на цифру 5 или 2

Ответ:
Metrofanovaa
Metrofanovaa
06.10.2020 16:48
Program z9;  Var a,del,del_2,i,j:integer; b,b_2: string;Begin  write('Введите число - '); readln(a);    del:= 5;  del_2:= 2;  i:= 0;  j:= 0;    while (a >= del) do  begin    if (a mod del = 0)       then       begin        b:= b + del + ' ';        i:= i + 1;      end;     del:= del + 10;  end;    while (a >= del_2) do  begin    if (a mod del_2 = 0)       then       begin        b_2:= b_2 + del_2 + ' ';        j:= j + 1;      end;     del_2:= del_2 + 2;  end;    writeln('Кол-во делителей заканчивающихся на 5 - ', i);  writeln(b);  writeln;  writeln('Кол-во делителей заканчивающихся на 2 - ', j);  writeln(b_2);  writeln;End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?