В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
назым24
назым24
14.01.2022 21:31 •  Информатика

Составить программу, формирующую одномерный массив, состоящий из n вещественных элементов. преобразовать массив таким образом, чтобы сначала располагались все отрицательные элементы, а потом – все положительные (элементы, равные 0, считать положительными). найти индекс максимального элемента массива. вычислить среднее арифметическое всех нечетных по порядку элементов массива.

Ответ:
КамиляУшурова
КамиляУшурова
06.10.2020 14:15
// PascalABC.NET 3.2, сборка 1492 от 03.07.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  a:=(a.Where(x->x<0)+a.Where(x->x>=0)).ToArray; a.Println;
  Writeln('Номер максимального элемента: ',a.IndexMax+1);
  Writeln('Среднее арифметическое нечетных по порядку: ',
      a.Where((x,i)->i.IsEven).Average)
end.

Пример
n= 15
18 -24 31 -4 -13 -45 24 -25 34 -42 -6 36 -50 40 -15
-24 -4 -13 -45 -25 -42 -6 -50 -15 18 31 24 34 36 40
Номер максимального элемента: 15
Среднее арифметическое нечетных по порядку: 2.75
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?