В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
OnAcHaYa2o2
OnAcHaYa2o2
26.11.2020 23:28 •  Информатика

Даны три целых числа a, b и с напишите программу, которая находит количество всех целых чисел от a до b, которые при умножении на число с будут являться четными числами входные данные: в первой строке вводятся три целых числа a, b и с (a< =b, a,b не больше 100 по модулю, 0< =с< =9) выходные данные: программа должна вывести одно число - количество всех целых чисел от a до b, которые при умножении на число с будут являться четными числами с ++

Ответ:
shevchenkotanu
shevchenkotanu
06.10.2020 13:47
#include <iostream>
using namespace std;
int main()
{
int a,b,c,k;
cin>>a;
cin>>b;
cin>>c;
k=0;
for(int i=a;i<=b;i++) if((i*c)%2==0)k=k+1;
cout<<k<<endl;
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?