Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
satinovgerman
11.01.2020 12:49 •
Информатика
Дан целочисленный массив a из 10 элементов. найти среднее арифметическое элементов массива. , pascalabc
Ответ:
vikakivi1206
06.10.2020 13:38
Program n1;
var a: array[1..10] of integer;
sum,i: integer;
begin
write('исходный массив: ');
for i:=1 to 10 do
begin
a[i]:=random(10);
write(a[i],' ');
sum:=sum+a[i];
end;
writeln;
writeln('срзнач: ',sum/10);
end.
0,0
(0 оценок)
Ответ:
Kannb
06.10.2020 13:38
// PascalABC.NET 3.2, сборка 1485 от 15.06.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-99,99); a.Println;
Writeln('Ср.арфиметическое равно ',a.Average:0:1)
end.
Пример
91 -37 67 -2 -66 -5 45 -44 79 61
Ср.арфиметическое равно 18.9
0,0
(0 оценок)
Популярные вопросы: Информатика
YourselfRuelfddd
09.04.2020 19:40
Вычислить площадь ромба, если известны длины его диагоналей. записать в виде программы....
3344227p06s57
07.03.2021 04:31
Перевести числа 41, 46 в фибоначчиеву систему счисления....
miroslavavernep09sr9
06.09.2022 21:59
Выполните операцию умножения над двоичными числами: а)1010*11; б)111*101; в)1010*111 объясните )...
маргарита00000000
06.09.2022 21:59
Последовательность изображений фильмы мультфильмы это...
DashaSi15
15.03.2022 21:13
Во время большой перемены проголодавшийся петя зашел в столовую с намерением поесть пирожков. находившийся рядом друг вася тут же посоветовал ему воспользоваться...
katia6173
05.03.2020 05:33
Проведите исследование и выясните что понимают под термином компьютерные сети...
valeraadyan
05.03.2020 05:33
Файл содержащий данные (рисунки, тексты)...
18larina18
05.03.2020 05:33
Программа pascal которая отделяет корни уравнения: составляет таблицу значений функции на интервале от 0 до 1,95 с шагом 0,15 и выделяет соседние значения аргументов...
ZaY40nOK
04.04.2022 02:51
Даны два действительных числа x и y. вычислить их сумму, разность, произведение и частное. напишите программу в паскаль...
УмНиК4980
01.09.2021 00:00
Дан двухмерный массив , в каждой его строке найти минимальный элемент....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a: array[1..10] of integer;
sum,i: integer;
begin
write('исходный массив: ');
for i:=1 to 10 do
begin
a[i]:=random(10);
write(a[i],' ');
sum:=sum+a[i];
end;
writeln;
writeln('срзнач: ',sum/10);
end.
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-99,99); a.Println;
Writeln('Ср.арфиметическое равно ',a.Average:0:1)
end.
Пример
91 -37 67 -2 -66 -5 45 -44 79 61
Ср.арфиметическое равно 18.9