В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Boikamen
Boikamen
01.11.2020 20:24 •  Информатика

Язык си написать программу,которая находит количество простых членов последовательности.

Ответ:
irkorwp0dj0n
irkorwp0dj0n
06.10.2020 13:37
#include<iostream>
#include<cmath>
using namespace std;

int main()
{
    setlocale(LC_ALL,"RUS");
    int N;
    cout <<"Введите количество чисел: ",cin >> N;
    cout <<"Введите сами числа: ";
    int k = 0;
    for(int i = 0; i < N; i++)
    {
        int A;
        cin >> A;
        if (A > 3)
        {
            int B = 1, K = sqrt(A), d = 2;
            while(d <= K)
            {
                if (A % d++ == 0)
                {
                    B = 0;
                    break;
                }
            }
            if (B) k++;
        }
        else if (A > 1) k++;
    }
    cout <<"Количество простых, среди введённых: "<<k;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?