В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
acivnatala
acivnatala
21.05.2020 07:46 •  Информатика

Написать программу, которая запрашивает имя файла и распечатывает из него только те строки, которые являются палиндромами(python)

Ответ:
texet1024
texet1024
06.10.2020 13:10
Python 2.7
def main('__init__')
    text=read(file)
    for i in strings(text)
        if i is i.palyndrome()
            print(i)
0,0(0 оценок)
Ответ:
Makc134
Makc134
06.10.2020 13:10
# Python 3.6.1

print("Введите имя файла: ",end='')
f = open(input())
for S in f:
   if S[-1] == '\n':
      S = S[:-1]
   L = len(S)
   B = 1
   for i in range(L//2):
      if S[i] != S[L-i-1]: B = 0
   if B == 1:
      print(S)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?