В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Поэзия
Поэзия
12.12.2022 18:29 •  Информатика

Напишите программу на языке программирования (или составьте алгоритм). дано натуральное число n, целые числа a a an , , 1 2 . определите номер предпоследнего из членов последовательности a a an , , 1 2 кратных 3; если членов, удовлетворяющих данным условиям, нет, то ответом должно быть «нет».

Ответ:
bogdannazarenkomen
bogdannazarenkomen
03.08.2020 14:48
Const n=10;
var a:array[1..n] of integer;
i,k: integer;
begin
Randomize;
for i:=1 to n do
 begin
 a[i]:=random(50);
 write(a[i]:3);
 end;
writeln;
k:=0;
i:=n;
while (i>0)and(k<2) do
 begin
 if a[i] mod 3 = 0 then k:=k+1;
 i:=i-1;
 end;
if k=2 then writeln('Искомый номер = ',i+1)
else writeln('Нет ');
end.

Пример:
22 13 42 48 26 2 18 30 11 31
Искомый номер = 7
0,0(0 оценок)
Ответ:
ilyamam07
ilyamam07
03.08.2020 14:48
Код Pascal:

Var
   n,m,i,A:integer;
Begin
Read(n);
m:=0;
i:=0;
For n:= 1 to n do
    Begin
    Read(A);
    if A mod 3 = 0 then
       if n > m then
          Begin
          i:=m;
          m:=n;
          End
    End;
if i = 0 then Write('нет')
else Write(i)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?