В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nastyayakushka2
nastyayakushka2
17.05.2021 00:45 •  Информатика

Нужна ) написать программу в python, которая запрашивает у пользователя имя файла со стихотворением и распечатывает строку с наибольшим количеством согласных букв.

Ответ:
Картофан7777777
Картофан7777777
06.10.2020 12:52
Python 3.6.1:

print('Введите путь к файлу: ')
f = open(input(),'r')
B = 'бвгджзклмнпрстфхцчшщ'
Max = 0
for S in f:
    k = 0
    for C in S.lower():
        if C in B:
            k+=1
    if k > Max:
        Max = k
        MaxS = S
print(MaxS)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?