В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
1AnastasiaP
1AnastasiaP
03.09.2022 06:33 •  Информатика

Вводится массив, состоящий из целых чисел. определите, сколько из них положительные. входные данные сначала задано число n — количество элементов в массиве (1≤n≤35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести одно целое число — количество положительных элементов массива. примеры ввод вывод 3 1 -2 0 1

Ответ:
Alenadobro97
Alenadobro97
06.10.2020 12:51
Program n1;
var n, k, i, c : integer; a:array[0..35] of integer;
begin
  read(N);
  if (N>=1)and(N<=35) then c:=n
  else
    begin
      writeln('error');
      read(N);
    end;
  for i:=1 to c do
    begin
      read(a[i]);
      if A[i]>0 then k:=k+1;
    end;
  writeln(k);
end.

Как то так
программа была скопирована из компилятора и там работала по условию
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?