В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
RRuslan619
RRuslan619
24.04.2022 23:57 •  Информатика

написать программу в паскале: надо заполнить массив случайными числами в диапазоне от 25 до 50, найти сумму четных чисел и их количество.

Ответ:
kokocuk01
kokocuk01
10.08.2020 08:52
// PascalABC.NET 3.2, сборка 1457 от 29.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),25,50); a.Println;
  var s:=a.Where(x->x.IsEven);
  Writeln('Четных чисел- ',s.Count,', их сумма равна ',s.Sum)
end.

Пример
n= 17
47 35 50 48 27 49 34 41 44 25 37 31 35 31 41 50 32
Четных чисел- 6, их сумма равна 258
0,0(0 оценок)
Ответ:
leron9999
leron9999
10.08.2020 08:52
Begin
  var a := arrrandom(readinteger('Введите размер массива:'), 25, 50).println;
  writeln('Кол-во четных чисел:', a.where(x -> x mod 2 = 0).count);
  writeln('Сумма четных чисел:', a.where(x -> x mod 2 = 0).sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?