В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
cuperkissers20
cuperkissers20
14.08.2021 03:04 •  Информатика

Составить программу нахождения цифр числа, состоящих на нечётных позициях (dev-c++)

Ответ:
Roland227
Roland227
26.08.2020 13:47
#include <iostream>
#include <locale>
using namespace std;
int main()
{
    setlocale(LC_ALL,"Rus");
    long long int A;
    cout << "Введите целое число: ", cin >> A;
    if (A < 0) A = -A;
    int i = 0;
    while (A > 0)
    {
        if (i++ % 2 != 0) cout << A % 10 << " ";
        A /= 10;
    }
    return 0;
}

Предполагается, что нумерация начинается права, с нулевой позиции.
Чтобы изменить номер начальной позиции, например, на единицу, нужно изменить десятую строку на int i = 1;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?