В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Yourstudentbook
Yourstudentbook
10.08.2022 00:26 •  Информатика

Напишите программу, которая заполняет массив из 20 элементов натуральными числами и считает разность произведений четных и нечетных элементов массива(paskal)

Ответ:
asdghkbf
asdghkbf
06.10.2020 12:25
var 
b: array[1..20] of BigInteger; 
pr, pr1, raz: BigInteger;

begin 
pr := 1; 
pr1 := 1; 
for var i := 1 to 20 do 
begin   
b[i] := random(100) + 10;   
write(b[i]+' ');   
if b[i] mod 2 = 0 then      
pr := pr * b[i];   
if b[i] mod 2 <> 0 then      
pr1 := pr1 * b[i];   
raz := pr - pr1; 
end; 
writeln(); 
writeln('Разница равна ', raz);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?