В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
metin2005
metin2005
10.08.2022 00:26 •  Информатика

Написать программу, определяющую количество дней в месяце алгоритм решения : переменная d имеет тип данных запись и содержит два поля: year – для хранения года и month – для месяца. пользователь вводит год и месяц. 8 оператор выбора case по номеру месяца определяет количество дней в нем. ситуация осложняется тем, что в феврале может быть как 28 дней, так и 29 (в високосный год). год является високосным, если делится без остатка на 4 и при этом не является последним годом столетия, за исключением того столетия, которое без остатка делится на 400.

Ответ:
frostdog0609
frostdog0609
10.08.2020 08:27
Type
   data = record
   year:integer;
   month:byte;
   End;

Var
   d:data;
Begin
Write('Год: ');ReadLn(d.year);
Write('Месяц: ');ReadLn(d.month);
Write('Количество дней в этом месяце: ');
Case d.month of
1,3,5,7,8,10,12:WriteLn(31);
4,6,9,11:WriteLn(30);
2:if (d.year mod 4 = 0)and((d.year mod 100 <> 0)or(d.year mod 400 = 0)) then WriteLn(29)
else WriteLn(28)
End;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?