В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
elyushik
elyushik
23.01.2023 11:37 •  Информатика

Составить программу вычисления двузначного числа, сумма кубов цифр которого равна n.

Ответ:
kataysinkevich
kataysinkevich
06.10.2020 12:24
// PascalABC.NET 3.2, сборка 1456 от 26.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var s:=Range(10,99).Where(x->(Power(x div 10,3)+Power(x mod 10,3)=n));
  if s.Count>0 then s.Println
  else Writeln('Нет таких чисел')
end.

Пример
n= 9
12 21
0,0(0 оценок)
Ответ:
Annuta88
Annuta88
06.10.2020 12:24
Var
   a,b,k:byte;
   n:integer;
Begin
Write('n = ');ReadLn(n);
k:=0;
For a:= 1 to 9 do
    For b:= 0 to 9 do
        if a*a*a+b*b*b = n then
           Begin
           Write(a,b,' ');
           k:=k+1
           End;
if k = 0 then Write('Таких чисел не существует.')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?