В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
yanaiweey
yanaiweey
12.01.2023 23:37 •  Информатика

Написать программу на языке с(си) пусть процедура socr (a,b,p,q) от целых параметров (b≠0) приводит дробь a/b к несократимому виду p/q. описать данную процедуру и использовать её для дроби 1+1/2+1/3++1/20 к несократимому виду c/d.

Ответ:
katia6747
katia6747
06.10.2020 12:21
#include<stdio.h>
#include<conio.h>

int Socr(long long int a, long long int b, long long int *p, long long int *q)
{
    long long int d;
    int c = 0;
    if (a)
    {
        if((float)a/b<0)
        {
            if(a<0) a=-a;
            if(b<0) b=-b;
            c = 1;
        }
        for(d = (a>b?b:a); (a%d!=0||b%d!=0); d--);
        if (c) *p = -a / d;
        else *p = a / d;
        *q = b / d;
    }
    else
    {
        *p = 0;
        *q = 1;
    }
    return 0;
}

int main(int argc, char *argv[])
{
    long long int a = 1, b, p = 1, q = 1;
    for(b = 2; b < 21; b++)
    {
        printf("%lli/%lli + 1/%d = ",p,q,b);
        Socr(p*b+q,q*b,&p,&q);
        printf("%lli/%lli\n",p,q);
    }
    getch();
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?