В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу,которая рассчитывает стоимость со стоимостью скидки 10% в том случае,если сумма покупки больше 1000 рублей и 20%,если cумма покупки больше 5 и 10 000 рублей. ввести стоимость покупки с учетом скидки и без ее учета.

Ответ:
Seregabludov98
Seregabludov98
06.10.2020 12:18
Var S:real;
Begin
Write('Введите сумму покупки: ');ReadLn(S);
Write('Сумма покупки с учётом скидки: ');
if S <= 1000 then WriteLn(S)
else if S > 10000 then WriteLn(S*0.8:0:2)
     else WriteLn(S*0.9:0:2);
WriteLn('Без учёта скидки: ',S:0:2);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?