В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
shiryaevkirill
shiryaevkirill
24.09.2022 08:35 •  Информатика

1. составьте программу в pascal abc. даны три числа. найти сумму двух наибольших из них. 2. составьте программу в pascal abc. для данного вещественного x найти значение следующей функции f, принимающей вещественные значения: f(x)=(2-х)/x2,если x> 0, иначе f(x)=6-х3 3. составьте программу в pascal abc. даны два числа. найти их сумму, разность и произведение.

Ответ:
гуманитарий0013
гуманитарий0013
06.10.2020 11:53
1 задача.
var a, b, c: integer;
begin
  write('Введите через пробел три числа: ');
  readln(a, b, c);
  if (a > b) then
    if (b > c) then
      write('Сумма двух наибольших чисел: ', a + b)
    else
      write('Сумма двух наибольших чисел: ', a + c)
  else
    if (c > a) then 
      write('Сумма двух наибольших чисел: ', c + b)
    else
      write('Сумма двух наибольших чисел: ', b + a)
end.

2 задача.
var x, f: real;
begin
  write('Введите значение x: ');
  readln(x);
  if (x > 0) then
    f := (2 - x) / (x * x)
  else
    f := 6 - (x * x * x);
  writeln('Значение функции при данном x: ', f)
end.

3 задача.
var a, b: integer;
  write('Введите через пробел два числа: ');
  readln(a, b);
  writeln('Сумма чисел: ', a + b);
  writeln('Разность чисел: ', a - b);
  writeln('Произведение чисел: ', a * b)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?