Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
SankohTew
22.01.2020 05:25 •
Информатика
Склавиатуры вводится n чисел. написать программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введённых чисел. значение n также вводится с клавиатуры. язык с++
Ответ:
Onewood
06.10.2020 11:31
#include<iostream>
using namespace std;
int main()
{
int n, A, P = 0, O = 0, N = 0;
cout << "n = ", cin >> n;
for (int i = 0; i < n; i++)
{
cin >> A;
if (A > 0) P++;
else if (A < 0) O++;
else N++;
}
cout << "( < 0): " << O;
cout << "\n( = 0): " << N;
cout << "\n( > 0): " << P;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
gopkomaks
30.05.2022 17:48
Питон,, 10 класс с вопросами...
киса2013438
21.06.2022 21:42
Самостоятельная работа, номер 3 (записать решение и ответ ) Какое значение будет присвоено переменной x, выполнения оператора x:=17 mod 4?4;1;4,25;0; (...
AkimMen
23.03.2022 10:26
, ДАЮ С Клавы вводится 20 чисел . написать программу которая ищет произведения нечетных чисел и выводит их на экран...
cJKYSIRJH
10.06.2021 20:17
Какой результат будет выведен на экран в результате выполнения программы , можно с объяснением?...
Saneitrix
04.11.2021 13:35
Сколько ячеек содержит диапазон G17:K23?...
yalunaluna
12.02.2023 12:09
Установите соответствие между величиной и ее типом *...
megais
27.03.2020 22:18
Определите значение b после выполнения алгоритма: *...
Roserum
10.06.2022 14:03
Дан массив натуральных чисел. Найти сумму элементов массива больших 10. Решить в виде программы на языке Паскаль....
cneze
03.10.2021 07:55
Если таблицу назвать line, то значение ‘Ян’ будет у величины *line[4]line[7]line[5]line[6]...
licach12
26.03.2020 20:53
Арифметические действия над числами пронумерованы следующим образом: 1 – сложение, 2 – вычитание, 3 – умножение, 4 – деление. Дан номер действия и два числа A и B...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main()
{
int n, A, P = 0, O = 0, N = 0;
cout << "n = ", cin >> n;
for (int i = 0; i < n; i++)
{
cin >> A;
if (A > 0) P++;
else if (A < 0) O++;
else N++;
}
cout << "( < 0): " << O;
cout << "\n( = 0): " << N;
cout << "\n( > 0): " << P;
return 0;
}