Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
nataliasuflik
13.08.2022 01:03 •
Информатика
Напишите программу паскаль: с клавиатуры вводится число от 0 до 1000 включительно. каждая цифра не превосходит 6. найти сумму промежуточных значений между наибольшей и наименьшей цифрами в числе?
Ответ:
svo20030227
16.08.2020 08:01
Попробуй, может сработает)
program num32;var
nums, i, min, max, a, i2, i3, sum: integer;begin
min := 7;
max := 0;
sum := 0;
readln(nums);
while nums <> 0 do
begin
if (((nums mod 10) > max)) then begin
max := nums mod 10;
end;
if (((nums mod 10) < min)) then begin
min := nums mod 10;
end;
nums := nums div 10;
end;
if (min > max) then begin
for i2 := max to min do
sum := sum + i2;
end;
if (max > min) then begin
for i2 := min to max do
sum := sum + i2;
end;
writeln(sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
tanysha29
19.03.2022 00:16
Как связаны мощность алфавита и разрядность двоичного кода, достаточного для кодирования всех символов этого алфавита....
tyahoo
17.06.2021 21:55
Какое минимальное количество бит потребуется для кодирования чисел меньших 1024? 1)1024 2)24 3)8 4)10...
СуПерБро123
06.02.2023 06:40
Расшифровать шифр цезаря : юосяыбыэ. используется алфавит....
Helryuwi12
16.12.2021 04:50
Задание по информатике Найдите все решения уравнения 2х(в 3 степени)-15sinx+0,5x-5=0 на отрезке [-5;5] с таблиц Excel...
Dudochka237
09.10.2022 05:45
Алексей учится работать с одномерными массивами. И он создал следующую программу: const mas : array[1..5] of integer=(13, 22, 3, 44, 5); var temp, n, i, j : integer;...
lubavoytenko003
07.02.2023 00:51
Сколько ячеек эт включает в себя следующие диапазоны: z100: ab109...
sofialesiuk
07.02.2023 00:51
Всплывает окно : reminder! your computer is not backed up, backup your file online today...
WiTeKHasky
07.02.2023 00:51
Запиши 5 разных имен файлов,удовлетворяющих маске *e? ? e.d? *...
AlexanderVard
06.10.2020 08:58
нужна . : класс 6 Прочитайте. Выпишите причастия, подчеркните в них суффиксы.Рванувшаяся в глубину омута рыбина свечкой выпрыгнула из воды. Рыбак увидел толстое,...
Тлопап
19.02.2021 15:55
12. Два трактора отправились одновременно из одного села в другое, расстояние между селами 36 км. Первый трактор прибыл в назначенный пункт на 15 минут раньше второготрактора,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
program num32;var
nums, i, min, max, a, i2, i3, sum: integer;begin
min := 7;
max := 0;
sum := 0;
readln(nums);
while nums <> 0 do
begin
if (((nums mod 10) > max)) then begin
max := nums mod 10;
end;
if (((nums mod 10) < min)) then begin
min := nums mod 10;
end;
nums := nums div 10;
end;
if (min > max) then begin
for i2 := max to min do
sum := sum + i2;
end;
if (max > min) then begin
for i2 := min to max do
sum := sum + i2;
end;
writeln(sum);
end.