В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
baus100
baus100
18.01.2022 23:35 •  Информатика

Напишите на с++ составьте программу для вычисления длин высот треугольника, у которого длины сторон a, b, c.

Ответ:
Cat125387
Cat125387
06.10.2020 10:51
#include<iostream>
#include<cmath>
using namespace std;

int main(){
    double a,b,c,p,S;
    cin >> a >> b >> c;
    p = (a + b + c)/2;
    S = sqrt(p * (p - a) * (p - b) * (p - c)); // Формула Герона
    cout << 2*S/a << "; " << 2*S/b << "; " << 2*S/c; // S = 1/2 a * h1 -> h1 = 2S / a
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?