В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
katerins08
katerins08
28.10.2022 16:00 •  Информатика

Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на языке паскаль)

Ответ:
wokef1
wokef1
10.08.2020 07:54
Var
a, b : integer;
begin
b:=1;
write('a?');
readln(a);
a := abs(a);
while a > 0 do
begin
b := b * a mod 10;
a := a div 10;
end;
if b mod 3 =0 then writeln('да')
else writeln('нет');
end.
0,0(0 оценок)
Ответ:
Прайм231
Прайм231
10.08.2020 07:54
Как-то так (фотография)
(работает и с отрицательными числами)
Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?