В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lyuda00777
lyuda00777
01.11.2020 01:22 •  Информатика

23 ! напишите программу, которая в последовательности натуральных чисел определяет количество нечетных чисел, кратных 3. программа получает на вход натуральные числа через клавиатуру, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести два число: длину последовательности (завершающий 0 не учитывается) и количество нечетных чисел, кратных 3.

Ответ:
vovadavydov56
vovadavydov56
06.10.2020 09:44
Progran hhh54;
var i,k,x:longint;
begin
  k:=0;
  for i:=1 to 1000 do;
    begin
      read (x);
      if (x mod 2 <> 0) and (x mod 3 = 0) then k:=k+1;
      if x=0 then begin
        break
      end;
    end;
  write (i-1,' ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?