В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
xacku1
xacku1
01.01.2021 03:43 •  Информатика

Напишите программу на языке си. даны натуральные числа a1, признак конца последовательности 222. найти количество 5 в последовательности и сумму последовательности

Ответ:
FaceStoom
FaceStoom
06.10.2020 08:54
#include <stdio.h>
#include <conio.h>
int main (int argc, char *argv[])
{
    int A, k = 0;
    double S = 0;
    scanf("%d", &A);
    while (A != 222)
    {
        if (A == 5) k++;
        S += A;
        scanf("%d", &A);
    }
    printf("k = %d\n",k);
    printf("S = %f",S);
    getch();
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?