В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
coolbembel
coolbembel
11.11.2022 06:23 •  Информатика

На вход программы поступает последовательность из n натуральных чисел. нужно выбрать из них произвольное количество чисел так, чтобы их сумма была максимальной и не делилась на 4. в результате программа должна вывести количество выбранных чисел и их сумму. если получить требуемую сумму невозможно, в качестве ответа нужно выдать 0. входные данные: на вход программе подаётся натуральное число n (n  1000), а затем n натуральных чисел, каждое из которых не превышает 10000. пример входных данных: 3 1 2 1 выходные данные: программа должна вывести два числа: сначала количество выбранных чисел, а затем их сумму. пример выходных данных для примера входных данных: 2 3 паскаль

Ответ:
katenkafialkaowy2yf
katenkafialkaowy2yf
06.10.2020 08:38
Var
  a, n, i, sum, c, min: integer;
 
begin
  sum := 0;
  c := 0;
  min := 10001;
  read(n);
  for i := 1 to n do begin
    read(a);
    sum := sum + a;
    c := c + 1;
    if(a < min) and (a mod 4 <> 0) then min := a;
  end;
  if(sum mod 4 = 0) and (min <> 10001) then begin sum := sum - min; c := c - 1; end;
  if(sum mod 4 = 0) then begin write(0); exit; end;
  writeln(c, ' ', sum);
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?