В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
XXL18
XXL18
21.08.2022 14:38 •  Информатика

1. написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3. написать программу, вычисляющую среднее арифметическое чисел, принадлежащих диапазону [–5; 5], среди пяти, вводимых с клавиатуры

Ответ:
Max82828
Max82828
10.08.2020 07:01
Program z1;
var a,i,sum:integer;
Begin
sum:=0;
for i:=1 to 5 do
begin;
read(a);
if (a<0) and (a mod 5=0) then
sum:=sum+a;
end;
writeln(sum);
End.

Program z2;
var a,p,i:integer;
Begin
p:=1;
for  i:= 1 to 5 do
begin;
read(a);
if (a mod 10=2) or (a mod 10=4) then
p:=p*a;
end;
writeln(p);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?