Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Оля2204202
30.09.2021 09:47 •
Информатика
Написать программу умножения двух чисел по методу аль-хорезми с++ 11 13 5 26 2 52 (вычёркиваем) 1 104 143 (ответ)
Ответ:
MelinMelomGii
26.04.2020 14:30
#include<iostream>
using namespace std;
int main()
{
int A,B,C = 0;
cin >> A >> B;
while(A > 1)
{
if (A % 2 != 0) C+=B;
B*=2;
A/=2;
}
cout << (C+=B);
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
ldudin
13.12.2021 00:07
1) материалы, представленные на носителях информации, характеризуются a) по назначению файлов b) по типу файлов c) по размеру файлов 2) сколько разновидностей форм...
Майя123
14.12.2022 05:34
Преобразуйте числа в заданную систему счисления A) 1010маленькая 2=x маленькая10 B) 31маленькая 10=x маленькая 2...
TOkenov
01.11.2021 14:17
З якого символу починається будь-яка формула в Excel? a. $ b. ( C.= d. +...
marilika3
29.03.2020 11:33
Язык программирования Си: Заполнить матрицу случайными числа- ми. Отобразить правую половину матрицы на левую зеркально симметрично относительно вертикальной оси....
Tuchka2oo5
12.05.2023 04:10
С9-10 класс . 1. ковалентная полярная и не полярная связь. примеры. 2. в воде обьемом 135мл растворили 15г поваренной соли . какова массовая доля соли процентах...
Fazzika
12.05.2023 04:10
Известно что n - натуральное число. является ли четным значение выражения: 1)n2; 2)2n+2; 3)n(n+1); 4)(2n - 1)(2n + 3); 5)(2n + 5)(4n - 2)(2n + 7)?...
Annnnf
12.05.2023 04:10
Составьте по два предложения со словами собиратель многоклеточный организм биология...
Anastasiz02
12.05.2023 04:10
Взаемозвязок будови й функции мязовых тканин...
ilyaachkasovggp06kg1
12.05.2023 04:10
Брис: дата создания, особенности, какое кол-во стран и что за страны входят...
Аделина2201
12.05.2023 04:10
Дтвердите адрес электронной почты и получите 10 . школьные знания.com задай вопрос из школьного предмета 5 - 9 классы язык 7+4 б над глаголами напишите вид и спряжение.;...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main()
{
int A,B,C = 0;
cin >> A >> B;
while(A > 1)
{
if (A % 2 != 0) C+=B;
B*=2;
A/=2;
}
cout << (C+=B);
return 0;
}