В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
keti261
keti261
16.04.2020 23:22 •  Информатика

Вкниге на одной странице помещается k строк. написать программу в паскале которая по номеру строки в тексте выводит на какой странице она находится и на какой строке.

Ответ:
metalnikovat
metalnikovat
06.10.2020 07:09
Если на странице k строк, то первая строка на первой странице имеет номер 1, на второй k + 1, на третьей 2k + 1, а четвертой 3k + 1 и т.д. Значит, если есть строка с номером x, то уже (x - 1) div k страниц полностью заполнены, эта строка находится на ((x - 1) div k + 1)-ой странице на ((x - 1) mod k + 1)-ом месте.

var
  k, x: integer;
begin
  read(k, x);
  write((x - 1) div k + 1, ':', (x - 1) mod k + 1)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?