В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
MackTraher
MackTraher
25.03.2023 22:36 •  Информатика

Составьте программу вычисления значений функции y=1/(x*x-1/(1+x*x)) для x=1,.

Ответ:
macsimys1
macsimys1
06.10.2020 06:32
1. Современное решение

// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Range(1,10).Tabulate(x->1/(x*x-1/(1+x*x))).Println
end.

Результат
(1,2) (2,0.263157894736842) (3,0.112359550561798) (4,0.0627306273062731) (5,0.0400616332819723) (6,0.0277986476333584) (7,0.0204164965291956) (8,0.0156287569127194) (9,0.0123475380213823) (10,0.0100009901970492)

2. Школьное решение

var
  x:integer;
begin
  for x:=1 to 10 do
    Writeln(x,' ',1/(x*x-1/(1+x*x)))
end.

Результат
1 2
2 0.263157894736842
3 0.112359550561798
4 0.0627306273062731
5 0.0400616332819723
6 0.0277986476333584
7 0.0204164965291956
8 0.0156287569127194
9 0.0123475380213823
10 0.0100009901970492
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?