Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
matveeva17vay
20.10.2021 01:41 •
Информатика
Дан массив а вещественного типа, содержащий 20 положительных и отрицательных элементов.найти сумму квадратов элементов массива.
Ответ:
ЮлияТимофеева
06.10.2020 05:57
// PascalABC.NET 3.2, сборка 1431 от 28.04.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(20,-99,99).Select(k->k/10).ToArray; a.Println;
Writeln('Сумма квадратов элементов: ',a.Select(x->x*x).Sum)
end.
Пример
-6.7 -6.9 -1.8 7 6.6 6 -8.5 -7.8 6.7 -1.6 -9.3 -4.5 5.9 -4.6 -3.6 -0.2 2.1 4.7 7.5 -5.7
Сумма квадратов элементов: 695.79
0,0
(0 оценок)
Популярные вопросы: Информатика
камран12
26.04.2022 05:57
программу рисования стрелочки на Python...
sakhnovavaleri1
09.02.2023 15:03
задание по ИКТ это онлайн мектеп (BilimLand)(((Надо выбрать ,,гиф ,типо как в ваьцапе...
sofiya113
14.02.2021 00:08
Программирование линейных и разветвляющихся алгоритмовДан программный код.Определи, какой результат получимна выходе, если х= 6....
daryaavdeeva01
04.05.2021 20:38
Нужен перевод в паскаль вопрос жизни или смертиa = int(b = int(chet = 0nechet = 0otvet = 0for i in range(a, b+1): if i % 2 == 0: chet += i else: nechet += iotvet =...
Kirillsveta0103
19.12.2022 14:04
Итак, условия учительница языка и мария ивановна, проверяя сочинение одного из учеников, наткнулась на следующие строки: « в город кемерово мы с семьёй переехали,...
Дура007
30.08.2020 00:32
Делаю всё по , но ноутбук не выдаёт после кода цифру , а переворачивает экран (как вернуть нашла , может , кто знает в чем проблема ) фото экрана есть (2) фото клавиатуры...
mariadenisovna
18.05.2021 22:07
Дано трехзначное число. если число сотен равно единицам то вывести нет иначе да. pascalabc...
катя4876
11.02.2022 10:05
Составить программу и блок схему для определения вида треугольника ( равносторонний , равнобедренный,произвольный ) если его стороны...
Psix007
23.09.2021 12:45
Нужно определите мощность алфавита, если вес одного символа равен 12 ...
khana3
28.05.2021 23:27
Решить данные напиши условие(в условие формулу написать) блок схему 30...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(20,-99,99).Select(k->k/10).ToArray; a.Println;
Writeln('Сумма квадратов элементов: ',a.Select(x->x*x).Sum)
end.
Пример
-6.7 -6.9 -1.8 7 6.6 6 -8.5 -7.8 6.7 -1.6 -9.3 -4.5 5.9 -4.6 -3.6 -0.2 2.1 4.7 7.5 -5.7
Сумма квадратов элементов: 695.79