В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lolololololololol4
Lolololololololol4
29.05.2020 03:18 •  Информатика

Напишите программу которая в последовательности целых чисел определяет минимальное положительное число кратное 5 программа получает на вход количество чисел в последовательности, а затем сами числа. последовательности всегда имеется положительное число делящееся на 5 количество чисел не превышает 1000 введённые числа мне абсолютной величине не превышает 30 000 программа должна вывести одно число минимальное положительное число, кратное 5 .пример работы программы входные данные 4 -5 10 6 25 выходные данные 10

Ответ:
konfetkamailrup0acjk
konfetkamailrup0acjk
06.10.2020 05:40
На C++
#include <iostream>using namespace std;int main(){
    /*
    k - это колличество чисел в последовательности
    now - считываемое число
    min - искомое значение
    */
    int k, now, min = 30001;
    cin >> k;
    for( k; k > 0; k--){
        cin >> now;
        if( (now % 5 == 0) && (now < min) ){
            min = now;
        }
    }    cout << min;  return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?