Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
MilkaV
11.09.2021 21:54 •
Информатика
9класс циклическое программирование 1.составьте программу которая вычисляет сумму натуральных чисел кратных 4 в диапазоне от 5 до 45 2.найти сумму нечетных чисел от 79 до 205 3.найти значение функции на отрезке [1; 10] с шагом 0,5
Ответ:
victoriya141005
06.10.2020 05:38
Первая программа:
Var S,A:integer;
Begin
S:=0;
For A:= 5 to 45 do
if A mod 4 = 0 then S:=S+A;
WriteLn('S = ',S);
End.
Результат работы программы:
S = 260
Вторая программа:
Var A,S:integer;
Begin
S:=0;
For A:= 79 to 205 do
if A mod 2 <> 0 then S:=S+A;
WriteLn('S = ',S);
End.
Результат работы программы:
S = 9088
Третья программа:
Var
x:byte;
Begin
WriteLn('f(x) = x^2');
For x:= 1 to 20 do
WriteLn('f(',x/2:3,') = ',Sqr(x/2))
End.
Результат работы программы:
f(x) = x^2
f(0.5) = 0.25
f( 1) = 1
f(1.5) = 2.25
f( 2) = 4
f(2.5) = 6.25
f( 3) = 9
f(3.5) = 12.25
f( 4) = 16
f(4.5) = 20.25
f( 5) = 25
f(5.5) = 30.25
f( 6) = 36
f(6.5) = 42.25
f( 7) = 49
f(7.5) = 56.25
f( 8) = 64
f(8.5) = 72.25
f( 9) = 81
f(9.5) = 90.25
f( 10) = 100
0,0
(0 оценок)
Популярные вопросы: Информатика
aleksaprincessa
20.04.2020 16:06
Задание на фото. Написать программу, которая рисует 3 квадрата.( Pascal abc...
1234567891248
20.11.2021 20:12
решить. как сделать? что надо делать? 100б....
школаскучаю
15.10.2020 16:08
Составьте программу на Паскале для заполнения массива из 100 чисел случайными значениями из диапазона от -30 до 30. Подсчитайте в этом массиве количество положительных...
настя7590
06.04.2021 03:55
чень Найти произведение положительных, сумму и количество отрицательных из 10 введенных целых значений: –5; 5; 36; –10; 98; 63; 2; 8; 37 ; –45. В отчет включить тексты...
Ленка6
17.10.2021 02:18
Географическая карта дает нам...
barbi18
30.10.2022 05:04
Заполните таблицу истинности ...
gyuzal1
02.06.2022 03:14
Задания на использование логических функций Задание №1 Определение годности претендента в баскетбольную команду Если Условие: если рост претендента больше или равен 180...
ЮляLoveYou
06.08.2022 05:05
В кодировке UTF-320 каждый символ кодируется 32 битами Костя написал текст бай, аэта, водой кереки, киргизы, норвежцы-народы...
ANNAAFANASYEVA1
29.12.2021 21:38
Каждый месяц программист Иван обновляет пароль от компьютера и использует для этого особый шифр. Правило шифрования: 5 ⇒ 3; 3 ⇒ 1; 2 ⇒ 4; 4 ⇒ 6 и т.д. После шифрования...
akakk
13.01.2022 18:57
Y=(k-2)! нужна программа в паскале!...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Var S,A:integer;
Begin
S:=0;
For A:= 5 to 45 do
if A mod 4 = 0 then S:=S+A;
WriteLn('S = ',S);
End.
Результат работы программы:
S = 260
Вторая программа:
Var A,S:integer;
Begin
S:=0;
For A:= 79 to 205 do
if A mod 2 <> 0 then S:=S+A;
WriteLn('S = ',S);
End.
Результат работы программы:
S = 9088
Третья программа:
Var
x:byte;
Begin
WriteLn('f(x) = x^2');
For x:= 1 to 20 do
WriteLn('f(',x/2:3,') = ',Sqr(x/2))
End.
Результат работы программы:
f(x) = x^2
f(0.5) = 0.25
f( 1) = 1
f(1.5) = 2.25
f( 2) = 4
f(2.5) = 6.25
f( 3) = 9
f(3.5) = 12.25
f( 4) = 16
f(4.5) = 20.25
f( 5) = 25
f(5.5) = 30.25
f( 6) = 36
f(6.5) = 42.25
f( 7) = 49
f(7.5) = 56.25
f( 8) = 64
f(8.5) = 72.25
f( 9) = 81
f(9.5) = 90.25
f( 10) = 100