В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
geniusdavidus
geniusdavidus
11.12.2020 10:19 •  Информатика

Напишите программу в паскале с div и mod! заранее ! вводится трехзначное целое число. получить новое число, записанное этими же цифрами, но в обратном порядке.

Ответ:
Марина24102008
Марина24102008
16.08.2020 06:25
Var A:integer;
Begin
Write('Введите трёхзначное число: ');ReadLn(A);
WriteLn(A mod 10,Abs((A div 10) mod 10),Abs(A div 100));
End.

Примеры работы программы:

Введите трёхзначное число: 123
321
Введите трёхзначное число: -987
-789
0,0(0 оценок)
Ответ:
studpetrp011ry
studpetrp011ry
16.08.2020 06:25
Var a,a1,a2,a3,b:integer;
begin
write('a = ');
readln(a);
a1:=abs(a) div 100;
a2:=abs(a) div 10 mod 10;
a3:=abs(a) mod 10;
b:=sign(a)*(a3*100+a2*10+a1);
writeln(b);
end.

Пример:
a = -456
-654
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?