В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nadezhdacvoboda
nadezhdacvoboda
07.10.2020 13:05 •  Информатика

Паскаль. составить программу для решения следующей : даны числа a, b - целые (< > 0). сократить дробь a/b. сначала найти нод этих двух чисел. затем знаменатель и числитель разделить на нод.

Ответ:
KatyaDihtiar3112
KatyaDihtiar3112
26.08.2020 12:25
// PascalABC.NET 3.2, сборка 1427 от 24.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var p,q:integer;
  Write('Введите числитель и знаменатель: '); Read(p,q);
  var a:=abs(p);
  var b:=abs(q);
  while b<>0 do begin a:=a mod b; Swap(a,b) end;
  p:=p div a;
  q:=q div a;
  Writeln('Результат: ',p,'/',q)
end.

Пример
Введите числитель и знаменатель: 1440 16200
Результат: 4/45
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?