В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
CarlJohnson1000
CarlJohnson1000
05.02.2021 23:54 •  Информатика

Напишите программу которая в последоательности натуральных чисел оределяет минимальное число оканчивающихся на 6. программа получает на вход количество чисел в последовательность, а затем сами числа. в последовательность всегда имеется число, оканчивающтхся на 6. количество чисел не превышает 1000. введённые числа не превышают 30000. программа должна вывести одно число - минимальное, оканчивающтхся на 6. входные данные 3, 26, 16, 36. выходные данные 16. !

Ответ:
неюляша2002
неюляша2002
16.08.2020 06:17
Var
   A,Min,N,i:integer;
Begin
Write('N = ');Read(N);
i:=1;
While Min mod 10 <> 6 do
   Begin
   Read(Min);
   i:=i+1
   End;
For i:= i to N do
    Begin
    Read(A);
    if A < Min then Min:=A;
    End;
WriteLn('Min = ',Min);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?