В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
SmaGe2017
SmaGe2017
03.06.2023 18:11 •  Информатика

Написать программу. дан массив целых чисел состоящий из 10 ячеек. найти произведение чисел больше 15 и вывести на экран.

Ответ:
cratospo234
cratospo234
06.10.2020 04:49
Uses Crt;
Const
   N = 10;
Var
   A:array[1..N] of integer;
   i:integer;
   P:real;
Begin
ClrScr;
Randomize;
Write('Исходный массив:');
P:=1;
For i:= 1 to N do
    Begin
    A[i]:=random(201)-100;
    Write(' ',A[i]);
    if A[i] > 15 then P:=P*A[i]
    End;
WriteLn;
if P = 1 then Write('В массиве нет чисел больше 15')
else WriteLn('P = ',P);
ReadLn
End.

Пример работы программы:

Исходный массив: -81 -43 -44 -89 47 80 -5 30 97 -39
P = 10941600
0,0(0 оценок)
Ответ:
suslenok91
suslenok91
06.10.2020 04:49
PascalABC.NET:

begin
  var a:=ArrRandom(10,1,30).Println;
  Writeln('P=',a.Where(x->x>15).Aggregate(1.0,(p,x)->p*x))
end.

Пример:
3 10 23 22 4 7 30 24 21 8
P=7650720
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?