В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
edelbi9512
edelbi9512
27.06.2021 06:23 •  Информатика

Напишите программу на языке паскаль. надо заменить меньшее из двух данных чисел на их среднее арифметическое а большее из них на среднее .

Ответ:
guast1
guast1
06.10.2020 04:47
Var
  a, b,sa,sg: real;

begin
  write('Введите a ');readln(a);
  write('Введите b ');readln(b);
  sa:=(a + b) / 2;
  sg:=sqrt(a * b);
  if a < b then begin
    a := sa;
    b := sg;
  end
  else begin
    a := sg;
    b := sa;
  end;
  writeln('a= ', a:0:2, ' ', 'b= ', b:0:2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?